diff setup.py @ 1036:0d7e5e290ea3

upload to pypi
author Nicolas Saunier <nicolas.saunier@polymtl.ca>
date Tue, 03 Jul 2018 16:47:37 -0400
parents cc5cb04b04b0
children d24deb61f550
line wrap: on
line diff
--- a/setup.py	Wed Jun 20 16:48:20 2018 -0400
+++ b/setup.py	Tue Jul 03 16:47:37 2018 -0400
@@ -1,13 +1,20 @@
-from setuptools import setup
+import setuptools
 
-setup(
+with open('README') as file:
+    long_description = file.read()
+
+setuptools.setup(
     name='trafficintelligence',
-    version=0.2,
-    description='Python modules of the Traffic Intelligence project',
+    version='0.2.2',
     author='Nicolas Saunier',
     author_email='nicolas.saunier@polymtl.ca',
     url='https://bitbucket.org/Nicolas/trafficintelligence',
-    packages=['trafficintelligence']
-    #py_modules = ['moving', 'utils']
-    #scripts=['helloworld']
+    packages=setuptools.find_packages(),
+    description='Python modules of the Traffic Intelligence project',
+    long_description=long_description,
+    classifiers=(
+        "Programming Language :: Python :: 3",
+        "License :: OSI Approved :: MIT License",
+        "Operating System :: OS Independent",
+    ),
 )